Ask a question

Ken Sheppard

Uninstall Exchange 2010 From Network Following Office365 Cutover

I need to uninstall Exchange 2010 from our network/domain.  Setup is a very old Exchange 2010 RTM (not SP1) install on a single server with a single mailbox DB and single PF DB.  All Exchange 2010 roles are on the same server.  I have already successfully migrated all mailboxes and PFs to Office365 using a cutover migration.  I know that I cannot simply use Add/Remove in the Windows Control Panel to remove Exchange 2010.  I've read quite a few articles on the process but they all appear to relate to larger environments with multiple mailbox DBs and OABs with multi-server Exchange deployments.  Mine is very small setup that only had 17 mailboxes. 

Do you have a migration guide that walks you through the proper removal of Exchange 2010 in a non-SBS environment?  The Exchange 2010 server is not a DC and is simply a member server running Windows Server 2008 R2. 

Thanks. 
Ken


  • Exchange Server 2010
asked12/06/2018 16:32
59 views
Add Comment
Last Activity 12/09/2018 18:02

1 Answer(s)

  • Mariette Knap
    Add Comment
    Ken Sheppard

    Thanks.  Looks like my account subscription needs to be renewed, which I will do.  Your support has always been exceptional and well worth the $ to have that extra layer of knowledge during these types of migrations.  

    Ken

    Mariette Knap

    Thanks Ken! Much appreciated and you made me smile :)


    replied 12/06/2018 17:18
    Ken Sheppard

    I read your Exchange 2010 removal guide last night and it looks pretty straight forward.  Because it's a single server with single mailbox DB as 1st and only 1 OAB, I presume your guide has us remove all data prior to running the uninstall to speed up the process.  It looks like only need to remove the arbitration mailboxes 1st in this type of smaller setup.  But my plan is to follow your guide to the letter.  I have a new system state backup from my DCs and full backup of Exchange server.  Plan is to perform this removal over the weekend during non-production hours.

    Thanks again.


    replied 12/07/2018 13:08
    Ken Sheppard

    Just started the removal process of Exchange 2010 on my network.  On the 1st step, you have us removing the Public Folders along with the System Public Folders.  On the 1st command, you have "Non_Ipm_Subtree" and I used this exactly in my command as well.  However, when I run a Get_PublicFolder -Server atlex01.wellspring.local to list my PFs, I only see one listed, which is IPM_Subtree.  Your 2 commands did finish without error by selecting A for all.  However, I still have the IPM_Subtree as well following your two command.  Should I edit your 1st command to include IPM_Subtree and not Non_Ipm_Subtree?

    These are the commands that I have run thus far with an admin PS.  Thanks.

    Get-PublicFolder -Server atlex01.wellspring.local "\Non_Ipm_Subtree" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server atlex01.wellspring.local -Recurse -ErrorAction:SilentlyContinue

    Get-PublicFolder -Server atlex01.wellspring.local "\" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server atlex01.wellspring.local -Recurse -ErrorAction:SilentlyContinue


    replied 12/09/2018 15:22
    Mariette Knap

    Hi Ken,

    Just those two Powershell commands should do it. Nothing else needed as far as I can see.


    replied 12/09/2018 16:10
    Ken Sheppard

    Out of curiosity, I ran the command without the ErrorAction:SilentyContinue on the end to see if there were any errors.  There was a red error for each PF it was trying to remove.  Please make sure that you specified the correct identity and that you have the correct permissions to delete it.  I'm using my domain admin, which has complete rights.  And I opened Exchange PS with admin.  I did some searching and it appears that I can use ADSIedit to manually remove the PF from AD.  What's your thought on doing this?  I know your older document used ADSIedit to forcefully remove Exchange, but clearly not the preferred method.  If I do use ADSIedit, I guess I can then delete the PF database using Remove-PublicFolderDatabase.

    1. Open Adsiedit
    2. Open configuration
    3. Expand Services --> Microsoft Exchange --> yourorgname --> administrative groups --> Exchange administrative group (xxxx) --> Databases --> public folder database. 
    4. Delete at these level.  You can see the CN of the server(s) in the right pane.

    replied 12/09/2018 16:22
    Mariette Knap

    We had a short discussion on Teamviewer and Skype on this issue. The Powershell commands do suppress errors with a reason. It does delete what it needs to delete and the 'errors' you see if you run the commands without error suppression give you false information. Exchange 2010 uninstalled gracefully and all is fine.


    replied 12/09/2018 18:02

    Reply
    replied 12/06/2018 16:41
Add an Answer