Ask a question

Rick Martin

Windows Server 2012 Essentials Connector will not run on new Windows 10 computer

Our environment is a fully patched Windows Server 2012 Essentials and I'm unable to join a new Windows 10 Pro version 1803. The client connector hangs and writes an application error event 1026, .net runtime  Application: ClientDeploy.exe Framework Version: v4.0.30319.


Rick Martin asked 09/09/2018 01:37
Jay Drinkwater

When do I change my router settings if I am migrating Exchange 2010 to 2016 but not yet getting rid of SBS 2011

I am following your very helpful "how-to-migrate-exchange-server-2010-from-sbs-2011-to-a-new-exchange-server-2016-on-windows-server-2016" and wish to complete the Exchange server migration before upgrading SBS 2011. I have got to the point of moving user mailboxes in step 11 and am looking ahead to pointing my incoming emails and access to the mailboxes for users off site and can't see any instructions about how or when to do this. Currently our router forwards all traffic to our public IP address for ports 25, 60 and 443 but I'm assuming this will have to change as I understand from you guide that Exchange 2010 won't proxy ...


Jay Drinkwater asked 09/07/2018 15:04
Art Saffran

Certification Authority Database

In the Migration Guide from 2012 to 2016, the steps to export the Certification Authority Database. The screenshots towards the end of this section show the Server 2012 R2 server. I assume the Certification Authority Database should be backed up on the new 2016 server. Is that correct? Also, minor note: the instructions say to stop the Certificate Services but not to restart. I assume they should be restarted and did so. Thanks. --Art


Art Saffran asked 09/03/2018 21:08
Art Saffran

Errors during Robocopy

During Robocopy from old to new server, there were Access Denied errors that hung up the process. I included the switches /R:0 and /W:0 to skip the files causing errors. Now I'd like to run Robocopy and get a list of the files and folders that are causing the errors so I can determine whether they need to be moved or can be left behind. I've searched but have not found a way to get just this list of errors. Is there a way to do this? Thanks. --Art


Art Saffran asked 09/05/2018 13:19
Art Saffran

Home folder on Server 2016 Essentials

On Server 2012, creation of a user account also created a home folder for users in \\server\users\%username%. Not sure if this was a feature of Server 2012 Essentials. In any case. all users had a home folder created with permissions assigned only to them. It gets mapped to a drive letter. After migrating to Server 2016 with Essentials Role, creation of user accounts does not also create a home folder...the drive mapping fails due to the lack of a network location for the mapping. Is this something that changed in 2016? I checked two other client ...


Art Saffran asked 09/06/2018 01:14
Larry Knopp

SBS 2011 / RWW / TS Gateway event ID 304, error 817

Existing SBS 2011 Domain, no problems. Am performing required remediation of failed PCI Compliance issues, and am "suddenly" unable to connect to Gateway through RWW. All RDP internally works fine. All other functions of RWW work fine. The specific event is : The user "DOMAIN\IAM-ADMIN", on client computer "xx.xx.xx.xx", met connection authorization policy and resource authorization policy requirements, but could not connect to resource "DOMAIN-SBS". The following error occurred: "817".   I have hunted through Event ID documentation, but am completely unable to find any reference to "Error 817" Any ...


Larry Knopp asked 09/06/2018 16:42
Dan Brown

2016 WSE URL for Remote doesn't default to remotewebaccess/remote

I've set up about 30 Server Essentials server for small businesses and am a huge fan of the easy Remote Web Access... in Server 2012 R2 Essentials, the RWA URL automatically defaulted to https//businessname.remotewebaccess.com/remote without any addtional setup, but in every 2016 Essentials server I've setup so far, the default is https://businessname.remotewebaccess.com/ without the "remote" at the end... that pulls up the IIS welcome page, which is fine, I can give users the direct link, but I'm wondering if there's an easy fix? I've tried changing the "default site" in IIS Manager, but that doesn't appear to work. ...


Dan Brown asked 09/03/2018 12:00
Dean Clarke

External Access to Exchange

Hi Mariette, I am about ready to run screaming from this migration. I have finally the mailboxes sorted - only 2 left to go and both over 50% complete.  Life got a bit easier when I found the Move Request section in the Exchange 2010 GUI - I was using Get-Mailbox but it does not show if there is a failure of a transfer.   The internal access to email and outlook appears to be working for all staff - both sending and receiving internally and externally.  Outlook appears to have reconfigured OK and when ...


Dean Clarke asked 09/03/2018 04:56
Dean Clarke

SBS2003 Exchange to Win2012R2/Exchange 2010 Migration

Hi, Hopefully this will be a nice simple question compared to my other issues.  I am waiting for the mailboxes to transfer as per step 15 of the SBS2003 to Exchange 2010 notes (and thanks again to Mariette for her help on this step).  I have run the get-mailbox command and there are still 5 mailboxes showing on the old server still waiting to transfer. Do I need to wait until they are showing on the new server before going onto step 16? Thanks Dean  


Dean Clarke asked 09/02/2018 02:32
Jean-Christophe BARREAU

Thin clients in Essentials Environment

Hi, Maybe a stupid question, but is there a way we would manage thin clients in Essentials manager? Is there a way to do it?   JC


Jean-Christophe BARREAU asked 09/02/2018 10:45
Art Saffran

Drive Mapping Group Policies not working on workstation

I modified the Group Policy for drive mapping after migration from Server 2012 to Server 2016 and tested on the two servers. This policy works fine on the servers. However, when I tested on a test workstation (Windows 7) the policy does not seem to work. Mapping still points to the old server shares. NOTE: Drive mapping policy is in the Default Domain Policy...that's how it was set on the old server...it worked fine there. Ran gpupdate /force numerous times and rebooted the test computer but it does not work. I don't ...


Art Saffran asked 09/02/2018 02:59
Shawn Lemay

DFS Folder Migration from one server to another for GPO Folder Redirects

This one has always boggled me...  If I have a server with folder redirects (using a GPO) and migrate the server - doesn't matter if I use RoboCopy or DFS to migrate the data, the first time that user logs in - it takes 5-10 (sometimes longer) minutes for the GPO to move the data again. If I move the data and delete on the old server - the GPO will kick off an error and I leave it on both, the GPO moves it again. There MUST be a way, to seamlessly move end ...


Shawn Lemay asked 09/01/2018 22:02
Art Saffran

How to get access to DHCP GUI tool

Migrating Server 2012 to 2016. I moved DHCP settings to the new server and removed DHCP role from the old DC and installed on the new DC. Did all this with PowerShell commands as in the Migration Guide.  I'd like to have the DHCP GUI added in addition to managing DHCP via PowerShell. DHCP doesn't appear in the Administrative Tools list. How can I add it? Many thanks. --Art


Art Saffran asked 08/31/2018 02:26
Dean Clarke

SBS2003 Exchange to Win2012R2/Exchange 2010 Migration

Hi, This is a migration from Exchange on SBS2003 to a new Win2012R2 server with Exchange 2010.  I started this project a while back, was unable to complete it so just getting back into it now.  I got up to step 15, moving the mailboxes and had to wait until I could get a clear run on the system. I finally got a chance to do this but when I did the Local Move request I got the below error.  It did not matter if I tried to move all mailboxes or just a single mailbox.  ...


Dean Clarke asked 08/08/2018 01:50
Jason Gough

The trust relationship between this workstation and the primary domain failed

Hi, I have a customer with a SBS2011 domain with the sbs2011 being the only server, the clients are a mixture of Windows 7 and Windows 10, we have had the above error pn 3 windows 7 computers over the last couple of days. Usually in this scenario I take the computer out of the domain and the re-add it but that does not work, it says that it has rejoined the domain, but when I go to re-boot and the login with the domain account I get the same error again, I have also tried  resetting ...


Jason Gough asked 08/28/2018 17:54
Greg Mohr

I have two servers in my domain, a DC (handles Server Essentials) and a File Server.

I have two servers and just finished migrating from SBS 2008 to Server 2016!  I have one question regarding the remote web access.   Since I have a separate file server with all shares for company  related files on that server, not on the DC that controls the Server Essentials experience, is there any way to get Shared Folders to display from the file server instead?  Also can it be restricted by security group.  i.e.:  Upper management gets Executive share, but no one else, Safety group gets the Safety & HR share and a couple of other general shares ...


Greg Mohr asked 08/24/2018 00:26
Jason Gough

Migrating from sbs 2011 to server 2016 standard FRS and DFS

Hi, I have a customer who has an sbs2011 server, we only use it for file and print and AD as email is already in 365. I have added a windows 2016 server to the domain, transferred all the file shares over and I have added it as a secondary dc. Having subscribed after the event I see that the document suggest that I should have upgraded FRS to Dfs prior to introducing the new server 2016, is this a big issue or can I do this at any time?.  


Jason Gough asked 08/27/2018 08:04
Eugene Palmer

Server Essentials Management service crashing

Hi, I have tried several things such as sfc /scannow as well as wbadmin delete catalog, and replaced the devicesinfo.xml with its backup. I've been looking at this thread- https://social.technet.microsoft.com/Forums/en-US/ff1f03a4-59d0-48bf-b116-53429b706a66/unable-to-start-windows-server-essentials-management-service-wsemgmtsvc The system event is- The Windows Server Essentials Management Service service terminated unexpectedly.  It has done this 3 time(s). The service will start, then stop a moment later.  I get two application error events Application: SharedServiceHost.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.Xml.XmlException    at System.Xml.XmlExceptionHelper.ThrowXmlException(System.Xml.XmlDictionaryReader, System.String, System.String, System.String, System.String) ...


Eugene Palmer asked 08/23/2018 17:14
C Berry

In place upgrade to 2016 Essentials and RWA issue - Requested value 'Broadband' was not found

Hi, I performed in-place upgrade as per the tutorial here, but had several issues getting RWA to work and also problems with Office365 integration. The Office365 issues were caused by duplicate registry keys resulting in ASP.Net mismatched assembly library issues, which I resolved by deleting the offending values. Still left with the issue below, which causes the RDP file not to be downloaded and therefore unable to remote desktop. I discovered that this was only with certain users and others work perfectly, even from the same PC and browser. So the issue must be caused by some ...


C Berry asked 08/17/2018 12:22
Terry Saliba

2FA options on Server Essentials 2012/2016

Hello I am becoming increasingly concerned that we have no 2FA options implemented for one of my clients, this morning had several login attempts. Has anyone implemented a 2FA option such as DUO successfully? Client would like to retain the RWA functionality. Before I delve any further, want to understand if anyone has implemented? Regards Terry


Terry Saliba asked 08/17/2018 09:49
David Moen

SBS2008 to Server 2016 - Exchange won't uninstall because IIS is running in 32 bit mode?

Hi all, In this case the customer was running a line of business application on IIS.  Exchange won't uninstall because IIS is "running in 32 bit mode".  My trigger finger is twitching on uninstalling the IIS role so that I can proceed with uninstalling Exchange.  Would there be any reason not to do that?  


David Moen asked 08/15/2018 20:59
Greg Mohr

When uninstalling sbs2008 Exchange role, I get a Mailbox Role Checks ...Failed

I get the following msg on the SBS 2008 box I am trying to get over the hump to decommission: c:\Program Files\Microsoft\Exchange Server\Bin>setup.com /mode:uninstall Welcome to Microsoft Exchange Server 2007 Unattended Setup Preparing Exchange Setup The following server roles will be removed     Mailbox Role     Client Access Role     Hub Transport Role     Management Tools Performing Microsoft Exchange Server Prerequisite Check     Mailbox Role Checks              ......................... FAILED      Uninstall cannot continue. Database 'Public Folder Database': The public folder database ...


Greg Mohr asked 08/12/2018 15:14
Jean-Christophe BARREAU

Change Essential Reports name

Hi, When we receive the reports for our customers on Essential, we would like to be able to personalize the report. In fact, often on our customer we name the main serveur SRVAD, so we receive all reports by mail with the same label : "Report of integrity for SRVAD"!!! DO you think it's would be possible to mention something like "Report for integrity for DOMAIN - SERVER" instead?    THanks,   JC    


Jean-Christophe BARREAU asked 08/05/2018 18:21
John Nork

Dual Purpose Wired/Wireless Laptop DNS Problem

We have several laptop computers that are workstations on a wired Server Essentials office network.  We have broadband Internet in the office, and the laptops work successfully there in terms of Internet access.  However, the laptops are also used in a traveling capacity where they access wireless networks outside of the office (e.g., home, airport, hotel, bookstore, restaurant, etc.).  In this environment the laptops cannot access any sites on the Internet, even though they show a strong connection to the local wireless network. My theory is that the traveling laptops are not getting DNS service.  As you ...


John Nork asked 08/08/2018 18:14
Shawn Lemay

Troubleshooting GUEST DC Time Sync

Following your setup guidelines here: https://www.server-essentials.com/support/articleid/121# Only using STEP 4... But the DC guest I have is showing that it's pointing to us.pool.ntp.org. Your instructions state, " The output must be ‘VM IC Time Synchronization Provider’." but it doesn't say how to reset it. I've tried a few different things to no luck. How do we reset this to be VM IC Time Synchronization Provider?


Shawn Lemay asked 08/02/2018 20:53
Subscribe to new questions