Start a discussion

Official Microsoft Support for SBS 2011 and 2008 has ended on January 14, 2020. Use promo code 'sbsmigration' and get 10% discount on your SBS 2011 or 2008 migration kit.
456 views
9 replies

Client PC unable to backup to WSE 2016 after upgrade to 1903 (May 2019 update)

I have a WSE 2016 server that has been backing up 7 PCs for the last few years. All clients were running Windows 10 1809. Clients were connected using the skipdomain process.

This week, after updating one of the client PCs to 1903, it is no longer able to backup to the server. In the Dashboard it shows as offline, and when opening the Launchpad on the client, the offline icon shows up after 3-4 seconds.

I have tried running ComputerConnector.exe to reconnect, and it finds the server, finds a computer with the same name (with all the warnings), lets me set it to wake for backup, and then exits quickly without error and no change in behavior.

Is there anyone who has a client PC updated to 1903 that is able to connect/backup?

Gordon Currie Gordon Currie
Published 06/08/2019 17:49
  • Windows 10
  • General
Add Comment
Mariette Knap

Hello Gordon,

We will have to wait for Microsoft to update WSE 2016. How long that will take is unknown to me and it would not be a surprise if it never gets fixed because the Essentials Experience role is deprecated and no longer available in 2019.

replied 06/08/2019 18:04
Ron Spitzer

I just wanted to comment that today, June 18, 2019 I decided to install Windows 10 1903 on a couple of my computers. Once installed I found that I cannot reconnect to my Server 2016 Essentials. When I run the connector is fails saying that is cannot start the configuration wizard at all. I cannot even get to the point where it finds my server. I sure wish that MS would check this before they release the version update into the wild. They seem to do this every time there is a major release of Windows 10. 

replied 06/18/2019 19:48
Gordon Currie

Your experience trying to re-connect via computerconnector.exe is similar to mine. When I run it, it finds the server, it warns me there is already a PC with that name (of course there is, I'm trying to re-connect), I click next and the program exits without any error.

When I open the Launchpad on the client, and sign in, it appears to sign in successfully for about 2 seconds.Then the little flag icon appears saying the server is offline. If I try and do a manual backup, it tries to connect and eventually fails with "Cannot connect to the Windows Server Essentials Client Computer Management Service."

Microsoft may never fix this as WSE 2016 is out of mainstream support. Even though thousands are using it.

replied 06/18/2019 20:38
Ron Spitzer

I think I figured mine out by trial and error. I had to make sure the previous connector software was completely uninstalled for the WIndows 10 machine, make sure the DNS server primary points to the WSE IP address and disable IPV6. Once I did all of those things the connector installed and seems to be working. A backup is currently running on the machine. Access to the shared folders seems to be working OK as well. If anything changes I will post again but for now all is working!

replied 06/18/2019 20:49
Gordon Currie

Excellent. Completely uninstalling AND re-inserting the skipdomain entries into the Registry did the trick. (I use skipdomain so I don't have to join to a domain, since this is a home server for me)

I guess the previous connector install must have confused the (re)connection process. Thanks for the post as it allowed me to fix my issue. Now I can update to 1903 on the rest of my machines.

 

replied 06/19/2019 01:37
Ron Spitzer

You are welcome, I am glad it helped someone else. I am sure there will be more people that encounter this problem. I too use the skipdomain as my server is a home server as well. I now have 4 machines updated and connected to the server again. 

replied 06/19/2019 01:42
Mariette Knap

Ron, if disabling IPv6 helped you solve this it means in most cases that your router is handing out IPv6 IP addresses and that DHCP IPv6 is running on that router. That is an unsupported configuration and will always cause issues.

replied 06/19/2019 06:41
Mariette Knap

I did a clean install of WSE 2016 + all updates and joined a clean Windows 10 1903 and found no problems at all.

replied 09/12/2019 14:47
Ron Spitzer

As previously stated by responders, it is crucial to remove the connector from the Windows 10 before upgrading it to 1903 or any other version. If you forgot you can run the uninstall after the upgrade and it should clean up everything, then reinstall the connector. 

Clean installs should always work properly but also note the issues around IPV6. I have had to disable IPV6 to get the connector to work in some machines. 

My Router does not have IPV6 enabled but disabling it on the machine seemed to have some effect. 

replied 09/12/2019 20:25
Last Activity 09/12/2019 20:25