Start a discussion

5230 views
7 replies

Essentials Dashboard and multi-factor / two-step authentication

So, integrated office 365 on windows server 2016 essentials and activated multi factor authentication following doc:

https://support.office.com/en-us/article/Set-up-multi-factor-authentication-for-Office-365-users-8f0454b2-f51a-4d9c-bcde-2c48e41621c6

Side effect the Windows Server Essentials Dashboard integration is now broken. User details : tab Microsoft Cloud , the following error is mentioned "The Microsoft Cloud services returned an error. Please try again later ". Changing admin user and using an app password or the initial password gives the same error as on user details level. Do not find any references that this is not supported 

however also nothing that it is supported 

anyone an idea ?

thx

Patrik Teughels Patrik Teughels
Published 11/16/2016 23:22
  • Windows Server Essentials 2016
Add Comment
Patrik Teughels

Office 365 team response on case was: this is not an issue with office 365, log a case with windows server. So how I solved it was to create an unlicensed office 365 user with a very long cryptic user name and very long password, this is the only user which is not MFA enabled. Gave that user for the moment following roles

  • Password administrator
  • Service administrator
  • Exchange administrator
  • User management administrator

And used this user account to configure the dashboard. Some more tweaking has to be done on this user his privileges to reduce it to a minimum, but left it at this for the moment



replied 10/28/2017 11:25
Ryan Becker

Years after this was written, it just saved my butt!  Yes, the Essentials role wizards most definitely do not support any type of MFA....  I've spent hours trying to figure this out and have even been working with MS support on this.  I found this thread while troubleshooting with them.  We both just learned something.  Such an easy fix!

replied 09/22/2020 20:08
Shawn Lemay

So were you able to find a way NOT creating this account? Our account, being a tenant, Microsoft requires us to now have 2FA turned on for all users no matter what. So this workaround no longer works for us, since the 2FA is site-wide regardless of the user.

replied 09/22/2020 20:20
User

I was wondering if you had a resolution to this.  dealing with the same issue MFA on essentials 2012 broke the integration.



thanks

replied 10/27/2017 22:04
Patrik Teughels

ok thx, I logged SR 616111791860812 in office 365 for this

keep you posted

replied 11/17/2016 22:56
Mariette Knap

Hello Patrik, I have not done this so I have no experience with this. Could well be that Microsoft thinks that for SMB's multifactor authentication is not widely used, specially for companies using Windows Server Essentials.

replied 11/17/2016 06:49
Shawn Lemay

I realize this is a 3 year old thread - but since Microsoft, last month, started enforcing that all partners must use multi factor authentication - this came to bite us in the behind this past month. The account we used stopped syncing. I found this post and wanted to confirm that 100% - this is the case! You must use an account that does not have multi factor authentication enabled as neither the accounts main password or application password will work. Both produce errors. The moment you disable MFA - the problem goes away.

replied 09/17/2019 13:36
Last Activity 09/22/2020 20:20