Start a discussion

4 views
0 replies

Server Essentials 2012R2 Office 365 Integration fails

There are huge numbers of threads about Office 365 integration failing with various versions of WSE. This week I moved a client who was using WSE 2012R2 from Gmail IMAP to O365. During the migration, I had one of my techs try to install AAD Connect but he was informed by the installer that it did not work with WSE. Fine. So, let's run the Dashboard wizard. Wrong answer. It failed with a rather innocuous response of "it didn't work".

So, off to Google I go. I looked at the log directory. Picked apart the log files. Googled BECWS and BEC Web Services every which way but loose. I checked the registry. Deleted registry keys. Added registry keys. Installed a Sharepoint 2012 Service Pack. Oh, yeah, I tried it all. I even poked around the nooks and crannies of this site. No joy.

Finally, I looked inward. I had a procedure I had written up last year and stored away on IT Glue. It described how I had reconnected Essentials to my client's Office 365 account after it had mysteriously lost connection. (This client was already on Office 365 using a peer-to-peer network before we added the WSE server and integrated on-prem AD with the cloud.) Here is what I had written:

With Windows Server Essentials (WSE) or Windows Server Essentials Experience (WSEE), we have the ability to integrate the Active Directory of Essentials with an existing instance of Office 365. The first production client successfully utilized this feature, but after initial implementation, clicking the Office 365 tab at the top of the WSE Dashboard showed no integration. Originally, it had pulled all accounts down from the cloud and these accounts were used to seed AD with current accounts.

I could find no way to reestablish connectivity within the Dashboard and I also found no help on the Internet, so this is what I did to fix the problem:

  • Restart the Windows Server Essentials Email Service service.
  • Click the Office 365 tab in the Dashboard.
  • Click Change the Office 365 administrator account in the right pane under Configuration Tasks.
  • Enter the User name for the Office 365 administrator for your client's account (it should be cached under the drop down if you were previously integrated).
  • Enter the Password for the Office 365 administrator account. This account should usually be the [email protected] account, not the "[email protected]" account. 
  • Click Next and let it Verify and Configure. If successful, it will ask you to restart the dashboard.
  • Click Restart Dashboard to complete this process.

You should now see the fields populated under the Office 365 tab.

If, during the interim, you had added a user to AD do the following to coordinate the new account to the cloud

  • Click on the user's name under the Users tab.
  • In the right pane under Username User Tasks, click Assign a Microsoft online account
  • In the popup, select Create a new Microsoft Online Services account (unless you already had put the same user in the cloud) and click Next.
  • If the new user will be assigned to an available Office 365 license, select the license from the Assign Microsoft Online Services licenses screen or leave it empty if it will be an unlicensed user account. 
  • Click Next and let it create/connect the new account.
  • The "new user" will be prompted to change their account password. If you know the password or you are assigning temporary passwords, you may change the password in AD or in the cloud and it will synchronize the two shortly.
  • Note: the user interface in the Dashboard will allow passwords to be pasted. This is very convenient when setting up multiple accounts.
The first bulleted step in my process instructed me to restart the "WSE Email Service" service. Well, that service was set to Disabled. I Googled that and found several references to the fact that it should normally be Disabled and that the Wizard would enable it as needed. Apparently this is not the case. I set the startup type to Automatic and tried to start the service. It started and then immediately stopped. OK. Whatever... I left it at Automatic and tried the Wizard again and this time voila! It worked. Perfectly. The first try.
 
Since this server had never been integrated with O365, who knows why the service was set that way or what the default was supposed to be. Regardless, it works now and I hope this might help you with a similar issue.
Randall Spangler Randall Spangler
Published 12/06/2018 00:07
  • Office 365
Add Comment
Last Activity 12/06/2018 00:07