Start a discussion

82 views
1 replies

Unable to take remote of windows 2012 R2 server after disabling TLS 1.0 & 1.1

Hello Team,

Due to security compliance i have to disable TLS 1.0 & 1.1 from my Windows 2012 R2 server, after disabling same i am unable to remote connection to specific server.

 

Error "This computer can’t connect to the remote computer,

i tried disabling same through registry as well using IIS crypto tool but same issue, also performed below steps searching throguh internet but not worked.

1.  using local Group Policy Editor you have to select the "Negotiate" Security Layer for RDP in "Computer Configuration\Administrative Templates\Windows\Components\Remote Desktop Services\Remote Desktop Session Host\Security" "Require use of specific security layer for remote (RDP) connections." and also select "Enabled

2.On the Remote Desktop Services server running the gateway role, open the Local Security Policy and navigate to Security Options - System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing. Change the security setting to Enabled. Reboot for the changes to take effect

 

Please help me to resolve same

nitin kadam nitin kadam
Published 10/26/2019 07:18
  • Windows Server 2012 R2 Standard
  • Remote Desktop Services
  • Remote Desktop Gateway
Add Comment
Mariette Knap

This is not Windows Server 2012 R2 Essentials, is it? If it is Standard Server you will need to use SQL Server Express instead of the WID, see Disabling TLS1.0 can cause RDS Connection Broker or RDMS to fail.

Good read: Disable TLS 1.0 on Windows Server 2012 R2 with Remote Desktop Services configured

replied 10/26/2019 18:13
Last Activity 10/26/2019 18:13