Start a discussion

1288 views
5 replies

Upgrade from WSE 2012 R2 to WSE 2016 - Missing users in Essentials control panel

I have tried doing an in place upgrade of a WSE 2012 R2 server to WSE 2016. After it was done and came back up, The Essentials control panel didn't show any users (although I can go to AD Users and Groups and they are there). Pressing "Add a user account" immediately results in a dialog "The task "Add a user account" did not complete successfully."

What can I look at to fix this?

OK, now for the long version. I am a former Windows Home Server user and moved to WSE 2012 R2 when it became available to fill the gap. My current WSE is running on older hardware and I wish to move it to VMWare, The move to VMWare seems to have gone OK (albeit, I have not enabled the NIC for the guest since I haven't shut down the currently running WSE box--so it's not fully tested). Before doing the WSE 2016 upgrade I went into the Essentials control panel and verified that the users actually still existed. I ran the in-place upgrade on the VM copy, and now my users are missing in the Essentials control panel (but still there in AD).

If anyone has any thoughts about what I can look at, that would be great.

Thanks,
Jim

Jim Foster Jim Foster
Published 12/29/2017 19:16
  • General
Add Comment
Mariette Knap

From an elevated Powershell window run

Import-WssUser –SamAccountName “username”

Let me know if that worked. If it does not work run from the same elevated Powershell Window

Add-WssLocalMachineCert

and reboot the server, try to run the Import-WssUser applet again and also try to add a user with the Add User wizard in the dashboard

replied 12/30/2017 08:51
Jim Foster

Uh... I don't have an Import-WssUser command. In fact, I don't have any Import-Wss* commands.

Do I need to import a missing module?

That said, I do have a whole host of Add-Wss* commands, including Add-WssLocalMachineCert and Add-WssUser.

Finally, you mentioned to try the Add User wizard in the dashboard. As I mentioned in my original post, that just returns the error "The task "Add a user account" did not complete successfully."

Thanks,
Jim

replied 12/30/2017 15:48
Jim Foster

Some web searches have revealed that the Import-Wss* commands have been removed from WSE 2016 for some reason. The last to have it was WSE 2012 R2.

replied 12/30/2017 16:31
Host

Purchase a subscription to migrate your server the supported way!


We excel at providing you the tutorials you need to get through that difficult migration project or configuration. It's like having a virtual coach looking over your shoulder. The documentation you'll find here is priceless. Our migration guides have screenshots of every step and Powershell scripts if applicable. 

One on one support is included in the IT Pro and IT Pro Mentor subscriptions. Success guaranteed!

replied 06/20/2018 12:17
Peter Rodyz

Though the post is pretty old, I still reply - it might help others. After a clean install of Windows Server 2016 Essentials I encountered the same problem. The solution for me was to check the services. Windows Server Essentials Management Service was not running (though it was set to "Automatic"). After starting the service manually I could add users. Btw also Windows Server 2016 Essentials Health Service and Windows Server 2016 Essentials Notification Service weren't running, though they were also set to "Automatic".

replied 08/11/2018 08:19
Last Activity 08/11/2018 08:19