Start a discussion

5458 views
16 replies

Yesterdays Feature update to Windows 10, version 1709

Did anyone have the same problem that when the "Feature update to Windows 10, version 1709" was finished and the pc finally rebooted . . . the computer was no longer connected to the server . . . if so how can this be fixed . . . I have 9 computers with this problem . . .

Thanks;

Leo

leo stapleton leo stapleton
Published 10/19/2017 17:58
  • Windows 10
Add Comment
Brad B

I just did another round of upgrades from Windows 10 1703 to Windows 10 1709. Despite the suggestion from TechNet, I left the Essentials Connector installed during the upgrade. As I expected, the Essentials Dashboard on the server as well as the Essentials Connector on the client were reporting issues after the upgrade.

I took Thomas's advise and used C:\Program Files\Windows Server\Bin\Client Deploy.exe. I ran this on the client while the client was still configured as part of the domain and while using the domain admin account on the PC, not the local admin account. (i.e., I did not put the PC name as part of the username during login).

After running Client Deploy.exe and deciding to reboot, it still wasn't showing as connected on the Dashboard.  So, I took the multiple reboots suggestion, again, adding in closing the dashboard on the server.  I closed the dashboard on the server, rebooted the client PC.  Once the PC was fully rebooted, I opened the dashboard and everything appears normal.

Also, as a reference to my previous post on this topic, it did not create new profiles marked .000 on these PCs.

This thread is a huge find for me, as this issue was negatively influencing my roll-out of the Essentials Connector. Client Deploy.exe and a couple of reboots are much easier than uninstalling Essentials Connector, completely disconnecting from the domain, upgrading, re-installing Essentials Connector, and any other extra steps needed.

Thanks, everyone!

replied 11/17/2017 20:20
Eugene Palmer

Yikes, I am also having problems with remote clients that were connected ok but are no longer able to connect.. I'll try the triple reboot and the clientdeploy.exe as well.

replied 11/12/2017 23:52
Brad B

Thanks Thomas - I'm not the OP but I'll give that a shot with the next round of upgrades.

I have had this same issue with Windows 10 1607, 1703 and 1709 - and this issue is a big deterrent from moving forward in rolling out the essentials connector based AD domain to the users.

I found this article on TechNet that indicates the Connector software should always be uninstalled before upgrading.  https://technet.microsoft.com/en-us/library/jj713510(v=ws.11).aspx#BKMK_13  This of course is a huge hassle.  (I found that article via this technet forum post: https://social.technet.microsoft.com/Forums/windowsserver/en-US/85970658-88f5-4b71-9016-072c8cfd902a/upgrade-to-the-windows-10-1703-version-broke-the-client-connector?forum=ws16essentials)

A new problem I've noticed with 1709 is that on some system it creates all new profiles (I'm not currently using Roaming profiles).  So I have profiles in C:\Users like this now:

  • admin.domain
  • admin.domain.000
  • user.domain
  • user.domain.000
  • user2.domain
  • user2.domain.000


where the profiles ending in .000 are the new profiles.   This issue is not consistent across all systems and 1709 is the first time I've encountered it.

replied 10/31/2017 17:07
Thomas Heuberger

If the connector was already installed it's not necessary (possible) to reinstall the connector over https:///connect. If you do that you will receive an network error. The update to 1709 kills the configuration. But you can start the following exe (on the client) to reregister the client:

C:\Program Files\Windows Server\Bin\ClientDeploy.exe

After this the client is online in the dashboard and the backup works also.

Hope this helps.

best regards
Thomas 

replied 10/24/2017 15:38
leo stapleton

Over the weekend I wiped the server and put 2016 Essentials back on and completed all the updates for it. Started to join the clients . . . the where all reset back before the update . . . no problems other then had to unjoin the domain and then rejoin after the connector was loaded . . . Then the clients again found the update and downloaded it . . . Out of 9 clients, although I had to reload the connector on most of them, they all worked OK. 2 I had to wipe and reload everything, then they were OK . . .So at least I can say I am current and up-to-date . . .

Leo

replied 10/24/2017 13:42
Mariette Knap

Timothy, I just upgraded a Windows 10 x64 English Retail 15063.0.170317 to version 1709 and after the first and second reboot of that client I also had trouble with the domain but after a third reboot everything works as expected and the client shows as 'online' in the Dashboard.

replied 10/21/2017 08:21
Mariette Knap

I am building a Windows 10 x86 English Enterprise 10586.0.151029 client and join that before updating to see what happens

replied 10/20/2017 19:02
Mariette Knap

Timothy, that is not worth the hassle at all if you see your story. I need to do more testing on older W10's and upgrade those to 1709. I must admit that I had not tested that. I only tested a clean install and join with the Connector and that seems to work just fine.

replied 10/20/2017 18:56
Timothy Cochran

Not sure if this feature update is worth the hassle... awful roll out on Microsoft part.  We were able to successfully upgrade my desktop machine to 1709 but only after I did the following:

  1. Drop from the domain
  2. Remove all profiles other than the one that started the update
  3. Remove all old driver packages.

Also there seems to be a bug with user profiles if you delete local and roaming profile from the machine:

once you log in after removing the profile the important system apps (edge, settings, etc, and user apps will not be loaded. The system still thinks user has all these applications loaded. If you do delete the profile, you will have to find the corresponding SID related to this account and remove entries from the registry that relate to the the user's SID. I believe they will be located in these areas below:

  1. Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\SessionData\
  2. Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\DataStore\
  3. Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\bam\UserSettings
  4. Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\UFH\ARP
replied 10/20/2017 18:53
Mariette Knap

I was not able to reproduce this issue on my test servers. You mention that you tried to reinstall the Connector software but when you tried it could not find the server, this seems unrelated to 1709 but possibly this is a DNS issue. If you still want schedule a Skype call I can have a look.

replied 10/20/2017 18:41
leo stapleton

Yes i will . . . just let me know what you need from me and thank you for your help . . .

replied 10/19/2017 19:37
Mariette Knap

We would like to open a case at Microsoft on this issue. Do you want to work with us on this? Seems very important.

replied 10/19/2017 19:23
leo stapleton

It was update Tuesday and I hit them on Wednesday . . . Everything updated at the same time . . . even restarted the server to make sure . . . oh well I guess it is wait and see time and I will reset the whole network back to Monday, Oct 16th and wait . . .

replied 10/19/2017 19:21
Mariette Knap

If both server and clients are fully updated and have Update Rollup 10 installed the only thing I can suggest is reinstalling the Connector software. If that does not work Microsoft has introduced another bug.

replied 10/19/2017 19:13
leo stapleton

I sorry went away from the site . . .

The computers are still on the domain, but the dashboard on the sever saws they are unavailable when they are active . . . so I would have to say it is a connection issue . . . I did try to run the connector software and got could not find server . . . was just hoping for a simple solution that would not take hours . . . but not very hopeful on that . . .

replied 10/19/2017 19:11
Mariette Knap

Does 'no longer connected' mean that the machine is no longer domain joined or is it a connector issue?

replied 10/19/2017 18:05

Last Activity 11/22/2017 08:14